Render Elements 0.6.92

Fixes and adds some things with Vray tags.

Advertisements

10 thoughts on “Render Elements 0.6.92

    • Rick Barret of Maxon was nice enough to do a 64bit Windows compile for me that I will post soon. There’s some code I need to update in the other versions just to make sure everything is exactly the same. When I can find the time I will do it – it should only take a few hours, and then I’ll post version 0.6.93. There are no additional improvements or bug fixes in that version.

      As for when… Well, unfortunately (and fortunately, too, I guess) my free time has been non-existent for the last few months, and will continue to be for the next two months, as well, as I am just swamped with animation projects.

      Render Elements will continue to be improved and refined as I get time. I think the current beta version is very good. I have only heard one complaint – a bug where Cinema crashes on quitting (which I will work on solving as my first priority for the next update). Other than that, people seem to be using the plugin in its current state with great success.

      In terms of official release – it will be released at some point this year. I can’t say anything about price, etc. but there is a possibility I may just put it out there for free.

  1. I’ve been looking for something like this for a long time. Right now I’m manually saving out copies of C4D files just to be able to render separate passes. I’d gladly pay $100 for a stable release!

    PS. This post isn’t tagged with the correct categories, making it hard to find this latest version when navigating via the Categories side bar.

    Keep up the good work!

  2. OK, bug report for 0.6.92:
    1. Having an unchecked effect such as “Object Glow” in the Render Settings, when saving out “As Save File” will enable that effect.
    The same goes for all disabled Multi-pass passes, they all get turned on, as well as disabled stuff like “Global Illumination.”

    2. The button “Generate .C4D Files” should be disabled (or at least show a warning) when no elements are checked in the list.

    3. When generating .C4D files, the dialog box (on OS X 10.5.6) button says “Open” when it should be “Save”

    Unfortunately for me, bug #1 is killing all the benefit I’d get from using it, since I have to manually open all the files and change the render settings afterwards.

    Keep up the good work, like I said, I’d happily pay for this!

    • I can verify these bugs. Thank you for pointing them out. I will try to fix. I agree with you that #1 is a high priority. I need to figure out what is going on there… The code seems fine, but Maxon changed a lot of things with render settings between version 10 and 11, so if anything was going to break, that would have been it.

      #2 and #3 should be easy to solve.

    • I started a bug reporting thread and added your bugs to that thread. Thanks for reporting them. I also posted a workaround for problem #1 in your list. Hopefully that works for you.

  3. Forgive me for asking, but since the last time we heard of RE win 64bit version was some months back, I thought I’d ask. Is the project still alive? 🙂

    • The project is definitely still alive – I just have a lot of other work going on right now that will last several more months. I try to chip away it it when I can.

      Here is Rick Barrett’s 64 bit compile for windows. I don’t have a windows 64bit machine, so I cannot test it. It is possible it could be very buggy.

      http://www.adamswaab.com/plugins/RenderElements.cdl64

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s